Opened 3 years ago

Closed 3 years ago

#7648 closed bug (duplicate)

please don't include mingw and mingw64 in main src tarball

Reported by: juhpetersen Owned by:
Priority: normal Milestone:
Component: Build System Version: 7.6.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


ghc >= 7.6 source tarballs are now over 100MB! :-(

106M  ghc-7.6.2-src.tar.bz2
106M  ghc-7.6.1-src.tar.bz2
 81M  ghc-7.6.1/ghc-tarballs/mingw64/x86_64-w64-mingw32-gcc-4.6.3-release-win64_rubenvb.tar.bz2
 25M  ghc-7.4.2-src.tar.bz2
 24M  ghc-7.0.4-src.tar.bz2

Would it please be possible to distribute the huge mingw64 and also the mingw tarballs in a separate tarball(s) for people building for Windows? They probably also do not change as often as GHC does anyway...?

Change History (1)

comment:1 Changed 3 years ago by igloo

  • difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. Closing as a duplicate of #7017

Note: See TracTickets for help on using tickets.