Opened 4 years ago

Closed 3 months ago

#7637 closed feature request (duplicate)

split-objs not supported for ARM

Reported by: singpolyma Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.7
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: arm
Type of failure: Compile-time performance bug Test Case:
Blocked By: Blocking:
Related Tickets: #8300 Differential Rev(s):
Wiki Page:

Change History (8)

comment:1 Changed 4 years ago by igloo

difficulty: Unknown
Milestone: 7.8.1

Thanks for the report.

comment:2 Changed 4 years ago by kgardas

Hi, the "as reported in" url points to probably completely different thread than it should, doesn't it?

comment:3 Changed 3 years ago by rwbarton

Looks like the email is now at http://www.haskell.org/pipermail/ghc-devs/2013-January/000190.html.

The original report is at http://www.haskell.org/pipermail/glasgow-haskell-users/2013-January/022137.html.

But I imagine nowadays people would want to use the LLVM backend on ARM... which doesn't seem to support split-objs either: see #8300.

comment:4 Changed 3 years ago by thoughtpolice

Milestone: 7.8.37.10.1

Moving to 7.10.1

comment:5 Changed 2 years ago by thoughtpolice

Milestone: 7.10.17.12.1

Moving to 7.12.1 milestone; if you feel this is an error and should be addressed sooner, please move it back to the 7.10.1 milestone.

comment:6 Changed 18 months ago by thoughtpolice

Milestone: 7.12.18.0.1

Milestone renamed

comment:7 Changed 13 months ago by thomie

Milestone: 8.0.1

comment:8 Changed 3 months ago by bgamari

Resolution: duplicate
Status: newclosed

Given that ARM is essentially solely supported by LLVM at this point, I think it's fair to call this a duplicate of #8300.

Note: See TracTickets for help on using tickets.