Opened 3 years ago

Closed 3 years ago

#7618 closed bug (duplicate)

Multiline prompt ignores custom prompt

Reported by: dunric Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.6.1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Other Test Case:
Blocked By: Blocking:
Related Tickets: #5209 Differential Rev(s):
Wiki Page:


  1. start a ghci session


  1. set some custom prompt

Prelude> :set prompt "GHCi> " GHCi>

  1. start a multiline command

GHCi> :{ Prelude|

Expected "GHCi| " as the custom prompt in multiline command.

Change History (2)

comment:1 Changed 3 years ago by dunric

Prelude> :set prompt "GHCi> "
GHCi> :{

comment:2 Changed 3 years ago by igloo

  • difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. Closing as it's (more-or-less) a duplicate of #7509.

Note: See TracTickets for help on using tickets.