#7587 closed bug (fixed)

Kind variables are not renamed

Reported by: monoidal Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty: Unknown
Test Case: ghci/scripts/T7587 Blocked By:
Blocking: Related Tickets: #7524

Description

ghci -XPolyKinds

Prelude> data A x y
Prelude> :k A
A :: k -> k -> *

should be k -> l -> *. The 'k's are allowed to be different, there is just a name collision.

Change History (3)

comment:1 Changed 15 months ago by goldfire

This may be a duplicate of #7524, but I don't know enough of the details to be sure.

comment:2 Changed 15 months ago by simonpj@…

commit 2cc42dbb6ff09f4105fe44fe1afe9ac08a140d44

Author: Simon Peyton Jones <simonpj@microsoft.com>
Date:   Tue Jan 22 17:01:30 2013 +0000

    When printing types in the interactive UI, take account of free variables
    
    Often the types we print are full-generalised, but in fact *kinds* are
    not, so we need to use tidyOpenType.
    
    Fixes Trac #7587

 compiler/main/HscMain.hs          |    2 ++
 compiler/main/InteractiveEval.hs  |    1 +
 compiler/main/PprTyThing.hs       |    7 ++++++-
 compiler/typecheck/TcRnDriver.lhs |    1 +
 4 files changed, 10 insertions(+), 1 deletions(-)

comment:3 Changed 15 months ago by simonpj

  • Difficulty set to Unknown
  • Resolution set to fixed
  • Status changed from new to closed
  • Test Case set to ghci/scripts/T7587

Thank you; fixed.

Note: See TracTickets for help on using tickets.