#7584 closed bug (invalid)

OperationalError: database is locked

Reported by: Heimdell Owned by:
Priority: normal Milestone:
Component: Compiler (FFI) Version: 7.6.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

How to Reproduce

While doing a GET operation on /report/8, Trac issued an internal error.

I just pressed on the 'ticket' column twice - to sort it descending.

Request parameters:

{'USER': u'Heimdell', 'asc': u'0', 'id': u'8', 'sort': u'ticket'}

System Information

Trac 0.11.6
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
setuptools 0.6c8
SQLite 3.5.9
pysqlite 2.3.2
Genshi 0.5.1
mod_python 3.3.1
Pygments 0.10
GIT 1.5.6.5
FullBlog? 0.1.1
RPC 1.0.6
CustomFieldAdmin? 0.2.2

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 229, in dispatch
    req.session.save()
  File "/usr/lib/python2.5/site-packages/trac/web/session.py", line 100, in save
    (self.sid,))
  File "/usr/lib/python2.5/site-packages/trac/db/util.py", line 64, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 80, in execute
    PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 59, in execute
    args or [])
  File "/usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 51, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (1)

comment:1 Changed 15 months ago by igloo

  • Difficulty set to Unknown
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the report.

I'm not sure what URL you were looking at, so I haven't been able to check whether it's reproducible, but the error was almost certainly a transient error due to the server being under too much load at the time.

Note: See TracTickets for help on using tickets.