Opened 9 years ago

Closed 9 years ago

#758 closed bug (duplicate)

Error compiling darcs on Mac OS X

Reported by: charles.gerungan@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.4.2
Keywords: Cc:
Operating System: MacOS X Architecture: powerpc
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

The only reason I'm using ghc is to compile darcs on Mac OS X 10.4.6 build 8I127, so I'm not really sure about anything that's happening here. I've attached the output of the console after compilation failed using Darwinports. Hope it helps.

charles@aluminum ~ $ sudo port -v upgrade darcs
Password:
---> Configuring darcs
checking for darcs... darcs
checking the release state... release
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for a BSD-compatible install... /usr/bin/install -c
checking for ghc... ghc
checking where GHC keeps its libraries... /opt/local/lib/ghc-6.4.2
checking GHC.Handle.openFd... NOT old API
checking GHC.Handle.openFd new API... okay
checking for module System.Posix.Signals(installHandler, Handler(..), Signal,

sigINT, sigHUP, sigABRT, sigALRM, sigTERM, sigPIPE,)... yes

checking for module Text.Regex( mkRegex, matchRegex, Regex )... yes
checking for module Debug.QuickCheck( quickCheck )... in package QuickCheck
checking for module Control.Monad.Error... in package util
checking for module Control.Monad.Error... yes
checking for module Text.ParserCombinators.Parsec... in package parsec
checking getCurrentDirectory... uses /
checking for module System.Posix.Files( createLink )... yes
checking createDirectoryIfMissing... has createDirectoryIfMissing
checking renameFile... okay
checking for module System.Posix.Files( fileMode, getFileStatus, setFileMode )... yes
checking for module System.Posix.Files( fileMode, getFileStatus, setFileMode )... yes
checking whether to optimize... yes
checking whether to profile... no
checking whether to use mmap... yes
checking whether to do PackedString debugging... no
checking whether to use wxhaskell... no
checking whether to build docs... yes
checking for latex... no
configure: WARNING: Cannot find latex in your path!
checking for dvips... no
configure: WARNING: Cannot find dvips in your path!
checking for latex2html... no
configure: WARNING: Cannot find latex2html in your path!
checking for htlatex... no
configure: WARNING: Cannot find htlatex in your path either!
checking for hevea... no
configure: WARNING: Cannot find hevea in your path either!
checking for sendmail... /usr/sbin/sendmail
checking for MAPISendMail in -lmapi32... no
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking for libcurl... 7.15.3
checking for curl_global_init in -lcurl... yes
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking term.h usability... yes
checking term.h presence... yes
checking for term.h... yes
checking for library containing tgetent... -lcurses
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for gzopen... yes
checking whether to enable Git support... no
checking for gdiff... no
checking for gnudiff... no
checking for diff... diff
checking for makensis.exe... no
checking whether byte ordering is bigendian... yes
configure: creating ./config.status
config.status: creating autoconf.mk
config.status: creating gitlib.h
config.status: creating Autoconf.lhs
config.status: creating ThisVersion.lhs
config.status: creating cgi/darcs.cgi
config.status: creating cgi/README
config.status: creating cgi/cgi.conf
config.status: executing config.command commands

The build is configured as follows:

bindir = ${exec_prefix}/bin
sbindir = ${exec_prefix}/sbin
mandir = /opt/local/share/man
datadir = ${prefix}/share
sysconfdir = ${prefix}/etc
libexecdir = ${exec_prefix}/libexec

Build Manual = no
Git support = no

If you want to adjust any of these values, edit autoconf.mk and
Autoconf.lhs -- or run configure with appropriate settings.

---> Building darcs with target all
rm -f Main.hi Main.o
ghc -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -optl-L/opt/local/lib -optl-L/opt/local/lib -optl-lcurl -optl-L/opt/local/lib -optl-L/opt/local/lib -optl-lssl -optl-lcrypto -optl-L/opt/local/lib -optl-lz -optl-lcurses -o stringify stringify.hs
/usr/bin/ld: warning prebinding disabled because dependent library: /opt/local/lib/libcurl.3.dylib is not prebound

test -f \Context.hs
echo unknown | ./stringify Context context > \Context.hs

Rebuild dependencies ...

test -f \Context.hs
echo unknown | ./stringify Context context > \Context.hs

ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c ThisVersion.lhs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c Autoconf.lhs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c Workaround.hs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c FastPackedString.hs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c Printer.lhs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c DarcsUtils.lhs
ghc-6.4.2: internal error: scavenge_stack: weird activation record found on stack: 441

Please report this as a compiler bug. See:
http://www.haskell.org/ghc/reportabug

make: * [DarcsUtils.o] Error 254
Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_devel_darcs/work/darcs-1.0.6" && PREFIX=/opt/local make all" returned error 2
Command output: rm -f Main.hi Main.o
ghc -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -optl-L/opt/local/lib -optl-L/opt/local/lib -optl-lcurl -optl-L/opt/local/lib -optl-L/opt/local/lib -optl-lssl -optl-lcrypto -optl-L/opt/local/lib -optl-lz -optl-lcurses -o stringify stringify.hs
/usr/bin/ld: warning prebinding disabled because dependent library: /opt/local/lib/libcurl.3.dylib is not prebound

test -f \Context.hs
echo unknown | ./stringify Context context > \Context.hs

Rebuild dependencies ...

test -f \Context.hs
echo unknown | ./stringify Context context > \Context.hs

ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c ThisVersion.lhs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c Autoconf.lhs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c Workaround.hs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c FastPackedString.hs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c Printer.lhs
ghc -I/opt/local/include -cpp -package QuickCheck -package util -package parsec -O -funbox-strict-fields -I/opt/local/include -Wall -Werror -I. -I/opt/local/include -DHAVE_CURSES -DHAVE_CURL -c DarcsUtils.lhs
ghc-6.4.2: internal error: scavenge_stack: weird activation record found on stack: 441

Please report this as a compiler bug. See:
http://www.haskell.org/ghc/reportabug

make: * [DarcsUtils.o] Error 254

Warning: the following items did not execute (for darcs): com.apple.destroot com.apple.build
Error: Unable to upgrade port: 1
charles@aluminum ~ $ ghc -v
Glasgow Haskell Compiler, Version 6.4.2, for Haskell 98, compiled by GHC version 6.4.2
Using package config file: /opt/local/lib/ghc-6.4.2/package.conf
Using package config file: /Users/charles/.ghc/powerpc-darwin-6.4.2/package.conf
Hsc static flags: -static
* Deleting temp files
Deleting:
ghc-6.4.2: no input files
Usage: For basic information, try the `--help' option.

Change History (2)

comment:1 Changed 9 years ago by gwright@…

This seems to be a duplicate of bug 751.

-Greg

comment:2 Changed 9 years ago by simonmar

  • Resolution set to duplicate
  • Status changed from new to closed

closed; dup of #751

Note: See TracTickets for help on using tickets.