Opened 4 years ago

Closed 7 months ago

#7521 closed bug (worksforme)

Accelerate examples does not compile with default value of -fsimpl-tick-factor

Reported by: eamsden Owned by:
Priority: normal Milestone: 8.0.1
Component: Compiler Version: 7.6.1
Keywords: Cc: chak, george.colpitts@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by simonpj)

When doing $ cabal build for: http://github.com/AccelerateHS/accelerate-examples (commit def2495a1e7bd88e444540c3494b8674da99e201):

[31 of 36] Compiling SMVM.Matrix      ( examples/tests/simple/SMVM/Matrix.hs, dist_accelerate/build/accelerate-examples/accelerate-examples-tmp/SMVM/Matrix.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 7.6.1 for x86_64-unknown-linux):
	Simplifier ticks exhausted
    When trying UnfoldingDone base:GHC.Base.returnIO1{v r5g} [gid]
    To increase the limit, use -fsimpl-tick-factor=N (default 100)
    If you need to do this, let GHC HQ know, and what factor you needed
    To see detailed counts use -ddump-simpl-stats
    Total ticks: 27960

Change History (17)

comment:1 Changed 4 years ago by simonpj

  • Description modified (diff)
  • difficulty set to Unknown

What -fsimpl-tick-factor makes it work?

Simon

comment:2 Changed 4 years ago by fmapE

I used -fsimpl-tick-factor=200 and it built.

comment:3 Changed 3 years ago by igloo

  • Milestone set to 7.8.1
  • Priority changed from normal to high

comment:4 Changed 2 years ago by George

Does this fail on 7.8.2?

comment:5 Changed 2 years ago by George

  • Cc george.colpitts@… added

comment:6 Changed 2 years ago by thoughtpolice

  • Milestone changed from 7.8.3 to 7.8.4

Moving to 7.8.4.

comment:7 Changed 23 months ago by thoughtpolice

  • Milestone changed from 7.8.4 to 7.10.1

Moving (in bulk) to 7.10.4

comment:8 Changed 21 months ago by thomie

  • Operating System changed from Linux to Unknown/Multiple

The file accelerate-examples.cabal in the latest version of that package (0.15.0.0) contains:

if impl(ghc >= 7.6)
   ghc-options:        -fsimpl-tick-factor=130

When I remove those lines, trying to build the package with ghc-7.8.3 still results in a Simplifier ticks exhausted panic.

Steps to reproduce:

$ sudo apt-get install c2hs freeglut3-dev
$ cabal get accelerate-examples==0.15.0.0
$ cd accelerate-examples
$ cabal install --dependencies-only
# `accelerate-cuda` might fail to install, just ignore that
# edit `accelerate-examples.cabal`
$ cabal build

comment:9 Changed 19 months ago by thoughtpolice

  • Milestone changed from 7.10.1 to 7.12.1

Moving to 7.12.1

comment:10 Changed 15 months ago by George

Should the subject/title, "Simplifier ticks exhausted when compiling Accelerate example" be changed since it is no longer accurate? Given that should the priority be changed?

comment:11 Changed 15 months ago by simonpj

  • Cc chak added

I'm not sure what you mean, George.

As I understand comment:8 everything is just fine so long as you don't meddle with the .cabal file. Or is there an actual problem.

Manuel?

Simon

comment:12 Changed 15 months ago by George

Right, there is no actual problem as long as you don't meddle with the Accelerate .cabal file but the subject/title of this ticket: ""Simplifier ticks exhausted when compiling Accelerate example" suggests there is. I guess a new subject would be something like "Accelerate examples does not compile with default value of -fsimpl-tick-factor" Once we have that title it isn't clear that the priority of this bug should be high, normal or low seems more appropriate to me.

Last edited 14 months ago by George (previous) (diff)

comment:13 Changed 15 months ago by simonpj

  • Summary changed from Simplifier ticks exhausted when compiling Accelerate example. to Accelerate examples does not compile with default value of -fsimpl-tick-factor

See also #8613, #9070, #8319, #10459

comment:14 Changed 14 months ago by bgamari

Also #10491

comment:15 follow-up: Changed 13 months ago by bgamari

  • Priority changed from high to normal

I'm not even convinced this should be considered to be a bug. Various programs require varying amounts of effort from the simplifier; it is fair to say that accelerate sits on the high end of this spectrum. Do we really want to set the default simplifier tick factor to accommodate this extreme case?

For the moment I'm going to lower the priority of this ticket, although arguably we could just close it.

comment:16 Changed 12 months ago by thoughtpolice

  • Milestone changed from 7.12.1 to 8.0.1

Milestone renamed

comment:17 in reply to: ↑ 15 Changed 7 months ago by thomie

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to bgamari:

this ticket [...] arguably we could just close it.

Yes, -fsimpl-tick-factor=130 is fine.

Note: See TracTickets for help on using tickets.