Opened 3 years ago

Closed 2 years ago

#7439 closed bug (invalid)

Include dynamic-by-default support in Cabal with GHC 7.6.2

Reported by: igloo Owned by: igloo
Priority: highest Milestone: 7.6.2
Component: Compiler Version: 7.6.1
Keywords: Cc: pho@…, ptrommler@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Ideally, we should ship GHC 7.6.2 with support for dynamic-by-default GHCs, so that any cabal-install programs built with 7.6.2 will also support 7.8.

Change History (3)

comment:1 Changed 3 years ago by PHO

  • Cc pho@… added

comment:2 Changed 3 years ago by trommler

  • Cc ptrommler@… added

comment:3 Changed 2 years ago by igloo

  • Resolution set to invalid
  • Status changed from new to closed

We went a different route in the end; Cabal HEAD now has support for -dynamic-too, which GHC 7.8 will use.

Note: See TracTickets for help on using tickets.