Opened 17 months ago

Closed 8 months ago

#7399 closed bug (fixed)

Test Posix004 fails in test-suite

Reported by: paulh Owned by: ezyang
Priority: normal Milestone: 7.8.1
Component: libraries/unix Version: 7.6.1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Incorrect result at runtime Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

After a standard build of ghc-7.6.1 on debian wheezy, the test-suite fails on the test posix004.

The error given is:

Wrong exit code (expected 0 , actual 1 )
Stdout:

Stderr:
posix004: unexpected termination cause

*** unexpected failure for posix004(normal)

Change History (6)

comment:1 Changed 12 months ago by igloo

  • Description modified (diff)
  • Difficulty set to Unknown

comment:2 Changed 12 months ago by igloo

  • Component changed from Compiler to libraries/unix
  • Milestone set to 7.8.1

Thanks for the report. I can't reproduce it on squeeze, but haven't tried on wheezy.

comment:3 Changed 9 months ago by ezyang

  • Owner set to ezyang

I can reproduce on Raring Ringtail, and am investigating.

comment:4 Changed 9 months ago by ezyang

I've boiled it down to a minimal C test case, it looks like the behavior of processes which receive SIGFPE is acting funny. http://stackoverflow.com/questions/17766149/program-with-sigfpe-exception-behaves-differently-under-gdb

comment:5 Changed 9 months ago by ezyang

  • Status changed from new to merge
commit 5692f5b8ed9e36ea7da4376fc7169354c55007bd
Author: Edward Z. Yang <ezyang@mit.edu>
Date:   Sat Jul 20 14:15:15 2013 -0700

    Fix #7399.
    
    Signed-off-by: Edward Z. Yang <ezyang@mit.edu>

comment:6 Changed 8 months ago by ezyang

  • Resolution set to fixed
  • Status changed from merge to closed

Actually, it's just a test fix, no point merging.

Note: See TracTickets for help on using tickets.