Changes between Initial Version and Version 1 of Ticket #7392


Ignore:
Timestamp:
Nov 5, 2012 2:37:56 AM (3 years ago)
Author:
simonpj
Comment:

Can you give explicit instructions to reproduce? Hackage only has Elm 0.3.6.2, and I don't know if you think that exposes the bug.

I had a look at download from the github repo, but it was going to install two dozen packages with muttering about breaking some alread-installed ones, so I lost heart.

Could you try with -dcore-lint. If that fails, send the output. If not, can you use -ddump-simpl -ddump-stg and send that?

Simon

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #7392

    • Property Difficulty changed from to Unknown
  • Ticket #7392 – Description

    initial v1  
    11Ran into this when trying to compile elm from git: 
    2  
     2{{{ 
    33$ cabal install 
    44Resolving dependencies... 
     
    1111        compiler/codeGen/CgCase.lhs:572:15-61: Irrefutable pattern failed for pattern ((CoreSyn.DEFAULT, 
    1212                                        deflt_absC) : others) 
    13  
    14  
    15 Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug 
    16  
     13}}} 
    1714Failed to install Elm-0.5.0.1