Opened 6 years ago

Closed 6 years ago

#7390 closed bug (worksforme)

Setup.hs: internal error: stg_ap_v_ret (MacOS)

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc: pho@…
Operating System: Unknown/Multiple Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

I was trying to build some haskell. Here's what happened:

$ runhaskell Setup.hs configure
Configuring c0c-3.9...
Setup.hs: At least the following dependencies are missing:
mtl -any, syb -any
$ runhaskell Setup.hs configure
$ runhaskell Setup.hs configure
$ runhaskell Setup.hs configure
Configuring c0c-3.9...
Setup.hs: At least the following dependencies are missing:
mtl -any, syb -any
$ runhaskell Setup.hs configure
$ runhaskell Setup.hs configure
$ runhaskell Setup.hs build
Setup.hs: Run the 'configure' command first.
$ runhaskell Setup.hs configure
$ runhaskell Setup.hs build                                               
Setup.hs: internal error: stg_ap_v_ret
    (GHC version 7.4.1 for x86_64_apple_darwin)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
$ runhaskell Setup.hs configure
$ runhaskell Setup.hs build                                               
$

In addition to the failure which it told me to report, it appears to be sometimes unable to locate the mtl and syb packages which I installed. I don't know if these are related. My platform is MacOS 10.6 on which I installed the tarball of ghc with gcc47 as my default gcc and haskell-platform version 2012.2.0.0 (built from source).

Change History (3)

comment:1 Changed 6 years ago by PHO

Cc: pho@… added

comment:2 Changed 6 years ago by igloo

Description: modified (diff)
difficulty: Unknown

comment:3 Changed 6 years ago by igloo

Resolution: worksforme
Status: newclosed

Thanks for the report. However, no-one else has reported this, so my suspicion is that it is a system-specific problem, perhaps dodgy hardware.

Because of this, and because we have no way to reproduce the problem, I'm closing this ticket.

Note: See TracTickets for help on using tickets.