Opened 3 years ago

Closed 3 years ago

#7357 closed bug (duplicate)

GHC.exe gives an internal error while linking vector's Monadic.hs

Reported by: kapilash Owned by:
Priority: normal Milestone: 7.8.1
Component: GHCi Version: 7.6.1
Keywords: Cc: saihemanth@…
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: GHCi crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description (last modified by igloo)

This is the command line output when building vector 0.10.0.1

c:\local\vector-0.10.0.1>cabal build
Building vector-0.10.0.1...
Preprocessing library vector-0.10.0.1...
[ 1 of 19] Compiling Data.Vector.Storable.Internal ( Data\Vector\Storable\Intern
al.hs, dist\build\Data\Vector\Storable\Internal.o )
[ 2 of 19] Compiling Data.Vector.Fusion.Util ( Data\Vector\Fusion\Util.hs, dist\
build\Data\Vector\Fusion\Util.o )
[ 3 of 19] Compiling Data.Vector.Fusion.Stream.Size ( Data\Vector\Fusion\Stream\
Size.hs, dist\build\Data\Vector\Fusion\Stream\Size.o )

Data\Vector\Fusion\Stream\Size.hs:25:10: Warning:
    No explicit method or default declaration for `*'
    In the instance declaration for `Num Size'

Data\Vector\Fusion\Stream\Size.hs:25:10: Warning:
    No explicit method or default declaration for `abs'
    In the instance declaration for `Num Size'

Data\Vector\Fusion\Stream\Size.hs:25:10: Warning:
    No explicit method or default declaration for `signum'
    In the instance declaration for `Num Size'
[ 4 of 19] Compiling Data.Vector.Internal.Check ( Data\Vector\Internal\Check.hs,
 dist\build\Data\Vector\Internal\Check.o )
[ 5 of 19] Compiling Data.Vector.Fusion.Stream.Monadic ( Data\Vector\Fusion\Stre
am\Monadic.hs, dist\build\Data\Vector\Fusion\Stream\Monadic.o )
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... ghc.exe: internal error: R_X86_64_PC32: Hig
h bits are set in 7fcb3ea95a0 for WaitForSingleObject
    (GHC version 7.6.1 for x86_64_unknown_mingw32)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Change History (5)

comment:1 Changed 3 years ago by igloo

  • difficulty set to Unknown
  • Milestone set to 7.8.1
  • Owner set to igloo

Thanks for the report. I'll take a look.

comment:2 Changed 3 years ago by igloo

  • Description modified (diff)

comment:3 Changed 3 years ago by igloo

  • Blocked By 3658 added
  • Component changed from Compiler to GHCi
  • Owner igloo deleted

I can't reproduce this for some reason.

Nevertheless, it would be fixed by #3658.

comment:4 Changed 3 years ago by bos

  • Blocked By 3658 removed

comment:5 Changed 3 years ago by bos

  • Resolution set to duplicate
  • Status changed from new to closed
  • Type of failure changed from Compile-time crash to GHCi crash

This is a dup of #7134.

Note: See TracTickets for help on using tickets.