Opened 3 years ago

Closed 3 years ago

#7322 closed bug (duplicate)

The 'impossible happened' compiling with -fext-core

Reported by: ydewit Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


This is what happened:

MrLemao :: Haskell/advanced-track/exercises ‹master*› » ghc --make -O ParTest0.hs -fext-core                  
[1 of 1] Compiling Main             ( ParTest0.hs, ParTest0.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 7.4.1 for i386-apple-darwin):
	MkExternalCore died: make_lit

Please report this as a GHC bug:

Attachments (1)

ParTest0.hs (517 bytes) - added by ydewit 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by ydewit

comment:1 Changed 3 years ago by michalt

  • Resolution set to duplicate
  • Status changed from new to closed

This seems to be a duplicate of #7239, so I'm closing.

Note: See TracTickets for help on using tickets.