Opened 5 years ago

Closed 2 years ago

#7305 closed bug (worksforme)

T5975a is broken on Windows

Reported by: simonmar Owned by:
Priority: normal Milestone: 8.0.1
Component: Test Suite Version: 7.6.1
Keywords: Cc:
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

=====> T5975a(ghci) 84 of 91 [0, 0, 0]
cd . && touch föøbàr1.hs
cd . && HC='c:/simonmar/ghc-validate/inplace/bin/ghc-stage2.exe' HC_OPTS='-dcore-lint -dcmm-lint -dno-debug-output -no-user-package-db -rtsopts -fno-ghci-history ' 'c:/simonmar/ghc-validate/inplace/bin/ghc-stage2.exe' --interactive -v0 -ignore-dot-ghci -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-db -rtsopts -fno-ghci-history     <T5975a.script >T5975a.run.stdout 2>T5975a.run.stderr
Actual stderr output differs from expected:
--- /dev/null   2012-10-08 13:22:40 +0100
+++ ./T5975a.run.stderr 2012-10-08 13:22:40 +0100
@@ -0,0 +1,2 @@
+
+<no location info>: can't find file: föøbàr1.hs

I've spent a bit of time looking at this, but I'm lost in a maze of Unicode encodings. So I'll just mark the test broken on Windows for now.

Change History (10)

comment:1 Changed 4 years ago by ezyang

Blocking: 8737 added

comment:2 Changed 4 years ago by ezyang

Blocking: 8737 removed

When using an MSYS2 build, the cause of the problem seems clearer: the Python test script is creating a file with the wrong name. You can see this by running:

#coding=utf-8
open('föøbàr1.hs', 'w').write("")

and then looking at the directory in the file explorer. I don't know what the right way to fix this is though.

comment:3 Changed 4 years ago by ezyang

It appears that it is not sufficient to just convert the pre_cmd/post_cmd to accept a Unicode string, as this breaks when using os.system, because Python attempts to transcode to ASCII. So we should convert everything to use subprocess/spawnv instead (both of which support Unicode), probably by manually invoking the shell we want.

comment:4 Changed 3 years ago by thoughtpolice

Milestone: 7.8.37.8.4

Moving to 7.8.4.

comment:5 Changed 3 years ago by thoughtpolice

Milestone: 7.8.47.10.1

Moving (in bulk) to 7.10.4

comment:6 Changed 3 years ago by thomie

Cc: gintas added
Operating System: Unknown/MultipleWindows

This is still an issue according to this email: https://www.haskell.org/pipermail/ghc-devs/2014-November/007146.html

comment:7 Changed 3 years ago by thoughtpolice

Milestone: 7.10.17.12.1

Moving to 7.12.1 milestone; if you feel this is an error and should be addressed sooner, please move it back to the 7.10.1 milestone.

comment:8 Changed 2 years ago by thomie

Cc: gintas removed
Keywords: newcomer added

comment:9 Changed 2 years ago by thoughtpolice

Milestone: 7.12.18.0.1

Milestone renamed

comment:10 Changed 2 years ago by thomie

Keywords: newcomer removed
Resolution: worksforme
Status: newclosed

Doesn't fail for me on Windows msys2.

Note: See TracTickets for help on using tickets.