Opened 19 months ago

Closed 19 months ago

Last modified 7 months ago

#7235 closed bug (duplicate)

"panic!" when compiling happstack-server-7.0.4

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.2
Keywords: Cc: lambdadusk@…
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: GHC rejects valid program Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I wanted to install happstack-server-7.0.4 for a project, then the compiler told me to file this as a bug:

$ cabal-dev install happstack-server-7.0.4
Resolving dependencies...
Configuring happstack-server-7.0.4...
Building happstack-server-7.0.4...
Preprocessing library happstack-server-7.0.4...
[ 1 of 38] Compiling Happstack.Server.Internal.LazyLiner ( src/Happstack/Server/Internal/LazyLiner.hs, dist/build/Happstack/Server/Internal/LazyLiner.o )
[ 2 of 38] Compiling Happstack.Server.Internal.SocketTH ( src/Happstack/Server/Internal/SocketTH.hs, dist/build/Happstack/Server/Internal/SocketTH.o )
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Loading package bytestring-0.9.2.1 ... linking ... done.
Loading package zlib-0.5.3.3 ... linking ... done.
Loading package xhtml-3000.2.1 ... linking ... done.
Loading package utf8-string-0.3.7 ... linking ... done.
Loading package array-0.4.0.0 ... linking ... done.
Loading package deepseq-1.3.0.0 ... linking ... done.
Loading package containers-0.5.0.0 ... linking ... done.
Loading package pretty-1.1.1.0 ... linking ... done.
Loading package template-haskell ... linking ... done.
Loading package text-0.11.2.3 ... linking ... done.
Loading package system-filepath-0.4.7 ... linking ... done.
Loading package syb-0.3.7 ... linking ... done.
Loading package transformers-0.3.0.0 ... linking ... done.
Loading package mtl-2.1.2 ... linking ... done.
Loading package parsec-3.1.3 ... linking ... done.
Loading package unix-2.5.1.1 ... linking ... done.
Loading package network-2.3.1.0 ... linking ... done.
Loading package sendfile-0.7.6 ... linking ... done.
Loading package base-unicode-symbols-0.2.2.4 ... linking ... done.
Loading package transformers-base-0.4.1 ... linking ... done.
Loading package monad-control-0.3.1.4 ... linking ... done.
Loading package html-1.0.1.2 ... linking ... done.
Loading package filepath-1.3.0.0 ... linking ... done.
Loading package old-locale-1.0.0.4 ... linking ... done.
Loading package old-time-1.1.0.0 ... linking ... done.
Loading package directory-1.1.0.2 ... linking ... done.
Loading package process-1.1.0.1 ... linking ... done.
Loading package time-1.4 ... linking ... done.
Loading package hslogger-1.2.0 ... linking ... done.
Loading package extensible-exceptions-0.1.1.4 ... linking ... done.
Loading package blaze-builder-0.3.1.0 ... linking ... done.
Loading package blaze-markup-0.5.1.0 ... linking ... done.
Loading package blaze-html-0.5.1.0 ... linking ... done.
Loading package base64-bytestring-0.1.2.0 ... linking ... done.
[ 3 of 38] Compiling Happstack.Server.Internal.Socket ( src/Happstack/Server/Internal/Socket.hs, dist/build/Happstack/Server/Internal/Socket.o )

src/Happstack/Server/Internal/Socket.hs:66:7:ghc: panic! (the 'impossible' happened)
  (GHC version 7.4.2 for x86_64-unknown-linux):
	Can't happen: pprExp (CompExp [])

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

cabal: Error: some packages failed to install:
happstack-server-7.0.4 failed during the building phase. The exception was:
ExitFailure 1

I get the exact same output for happstack-server-7.0.3 as well. I am quite stumped with this one because just minutes ago, I was able to compile it just fine.

Change History (3)

comment:1 Changed 19 months ago by igloo

  • Difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

I suspect that what's happened here is that you've upgraded your template-haskell library, and the version you now have is incompatible with your GHC. I'm therefore closing this as a duplicate of #7200.

Please reopen if you think something else is going on.

comment:2 Changed 19 months ago by simonpj

Another possiblity is that Happstack is generating an empty comprehension CompExp[]. In that case, what should happen? The pretty printer probably shouldn't fall over. Maybe it should print <<empty CompE>> in the pretty-printed output? I'll do that for now, and for the other call to error in TH.Ppr.


comment:3 Changed 7 months ago by ivan.perez

I understand that this is an old, closed ticket, but I'm hitting this when I try to compile a package. I'm not even sure it's the same bug.

I'm on Ubuntu 12.10, I'm adding the package list that cabal selects so that you have more information about what I'm using. This is a fresh-new installation: I removed my .ghc and .cabal dirs before compiling this.

Configuring postgresql-simple-0.3.7.1...
Building postgresql-simple-0.3.7.1...
Preprocessing library postgresql-simple-0.3.7.1...

[...removed by me...]

[26 of 32] Compiling Database.PostgreSQL.Simple.FromField ( src/Database/PostgreSQL/Simple/FromField.hs, dist/build/Database/PostgreSQL/Simple/FromField.o )
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Loading package array-0.4.0.1 ... linking ... done.
Loading package deepseq-1.3.0.1 ... linking ... done.
Loading package bytestring-0.10.2.0 ... linking ... done.
Loading package postgresql-libpq-0.8.2.4 ... linking ... done.
Loading package text-0.11.3.1 ... linking ... done.
Loading package blaze-builder-0.3.1.1 ... linking ... done.
Loading package old-locale-1.0.0.5 ... linking ... done.
Loading package time-1.4.1 ... linking ... done.
Loading package primitive-0.5.0.1 ... linking ... done.
Loading package vector-0.10.0.1 ... linking ... done.
Loading package blaze-textual-0.2.0.8 ... linking ... done.
Loading package containers-0.5.3.1 ... linking ... done.
Loading package attoparsec-0.10.4.0 ... linking ... done.
Loading package dlist-0.5 ... linking ... done.
Loading package hashable-1.1.2.5 ... linking ... done.
Loading package transformers-0.3.0.0 ... linking ... done.
Loading package mtl-2.1.2 ... linking ... done.
Loading package syb-0.3.7 ... linking ... done.
Loading package pretty-1.1.1.0 ... linking ... done.
Loading package template-haskell ... linking ... done.
Loading package unordered-containers-0.2.3.2 ... linking ... done.
Loading package aeson-0.6.2.0 ... linking ... done.

src/Database/PostgreSQL/Simple/FromField.hs:485:11:ghc: panic! (the 'impossible' happened)
  (GHC version 7.4.2 for x86_64-unknown-linux):
	Can't happen: pprExp (CompExp [])
Last edited 7 months ago by ivan.perez (previous) (diff)
Note: See TracTickets for help on using tickets.