#7212 closed bug (wontfix)

GHCi segmentation fault

Reported by: zenzike Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.4.1
Keywords: Cc:
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Using OS X 10.6.8 on a 2.5 GHz Intel Core i5 machine. XCode 4.0.2 installed. Haskell Platform 2012.2.0.0 installed. GHCi non-deterministically produces a segmentation fault on the command line when launched.

479-mac-ta:~ nwu$ ghci -v
GHCi, version 7.4.1: http://www.haskell.org/ghc/  :? for help
Glasgow Haskell Compiler, Version 7.4.1, stage 2 booted by GHC version 7.0.4
Using binary package database: /Library/Frameworks/GHC.framework/Versions/7.4.1-x86_64/usr/lib/ghc-7.4.1/package.conf.d/package.cache
wired-in package ghc-prim mapped to ghc-prim-0.2.0.0-c2ff696e5b8ec4d4b2bc2e42085fe471
wired-in package integer-gmp mapped to integer-gmp-0.4.0.0-3cccac07aef8e27023f605c1f45bdf74
wired-in package base mapped to base-4.5.0.0-7aff24101508c8e98d083dc12ec4756b
wired-in package rts mapped to builtin_rts
wired-in package template-haskell mapped to template-haskell-2.7.0.0-c77fdef202828dcc7ffefd2eb5f20430
wired-in package dph-seq not found.
wired-in package dph-par not found.
Hsc static flags: -static
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
*** gcc:
'/usr/bin/gcc' '-m64' '-fno-stack-protector' '-m64' '-L/Library/Frameworks/GHC.framework/Versions/7.4.1-x86_64/usr/lib/ghc-7.4.1/base-4.5.0.0' '--print-file-name' 'libiconv.dylib'
Loading package base ... linking ... done.
Segmentation fault

Sometimes launching ghci works without problems, sometimes it simply segfaults as above.

Change History (1)

comment:1 Changed 23 months ago by simonmar

  • Difficulty set to Unknown
  • Resolution set to wontfix
  • Status changed from new to closed

This problem is caused by (we think) having an XCode that is too old. See #6138, and http://trac.haskell.org/haskell-platform/ticket/199 and the mailing list thread pointed to from there.

Note: See TracTickets for help on using tickets.