Opened 9 years ago

Closed 9 years ago

#717 closed bug (duplicate)

Compiling large constant data structure fails

Reported by: luettich@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.4.1
Keywords: Cc:
Operating System: MacOS X Architecture: powerpc
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I am trying to compile a large data strcture as list into a Haskell module (Source is linked below) and GHC fails with this error message:

Compiling CASL_DL.PredefinedSign ( ./CASL_DL/PredefinedSign.hs, ./CASL_DL/PredefinedSign.o ) /tmp/ghc12137.s:30942:Fixup of 39588 too large for field width of 16 bits /tmp/ghc12137.s:30939:Fixup of 39600 too large for field width of 16 bits

With the flag '-fvia-C', GHC can compile the file without an error.

Sources, including a Makefile with used GHC options, are available at sources

Change History (1)

comment:1 Changed 9 years ago by simonmar

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #709

Note: See TracTickets for help on using tickets.