#7138 closed bug (fixed)

GHCi does no respect -ignore-dot-ghci anymore

Reported by: SimonHengel Owned by: pcapriotti
Priority: highest Milestone: 7.6.1
Component: GHCi Version: 7.6.1-rc1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Incorrect result at runtime Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Steps to reproduce:

$ echo foobar > .ghci
$ ghci -ignore-dot-ghci

Expected results: GHCi is started without any errors.

Actual result: GHCi reports "Not in scope: `foobar'".

Change History (4)

comment:1 Changed 21 months ago by igloo

  • Difficulty set to Unknown
  • Milestone set to 7.6.1
  • Priority changed from normal to highest

We think this is caused by the "-i" flag consuming this argument.

comment:2 Changed 21 months ago by pcapriotti

  • Owner set to pcapriotti

comment:3 Changed 21 months ago by p.capriotti@…

commit f78b31a36b5b49afbdea199269319faca261c898

Author: Paolo Capriotti <p.capriotti@gmail.com>
Date:   Mon Aug 13 12:48:29 2012 +0100

    Fix ambiguous flag resolution (#7138)
    
    Pick longest flag when more than one matches in findArg.
    
    This fixes an issue where -ignore-dot-ghci wasn't honored, because the
    flag was parsed as "-i gnore-dot-ghci".

 compiler/main/CmdLineParser.hs |   12 +++++++-----
 1 files changed, 7 insertions(+), 5 deletions(-)

comment:4 Changed 21 months ago by pcapriotti

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.