Opened 8 years ago

Closed 8 years ago

#712 closed bug (fixed)

getDirectoryContents: failed (No error)

Reported by: simonmar Owned by:
Priority: normal Milestone: 6.4.2
Component: Compiler Version: 6.4.1
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Reported on ghc-bugs by martin.boeker@…:

this error has been reported before and was fixed in ghc 6.4.1 but has been revived in ghc 6.4.2:

test3.exe: .: getDirectoryContents: failed (No error)

module Main where

import System.Directory

main =    do s <- getDirectoryContents "."
           putStr (concat s)

This works fine for ghc 6.4.1 bld1. The error is encountered in 6.4.2 snapshots from Feb. 25 and newer (elder ones have not tested), and the same snapshots with the MinGW files from afore mentioned ghc 6.4.1 (it's not the MinGW).

My system is: Cygwin (WinXP) and ghc 6.4.1 bld1 or 6.4.2 (Cajal works better).

I would like to add a wish: could we have a native Cygwin port?


See also, previous incarnation of this bug (perhaps):

http://www.haskell.org//pipermail/glasgow-haskell-bugs/2005-July/005338.html

Change History (2)

comment:1 Changed 8 years ago by simonpj

The previous bug was in the handling of .bss sections for relocatable
object files in the RTS linker -- the fix is included in STABLE. It's
not clear that it would apply in this context though.

I'm not able to reproduce this one with last night's STABLE build.
Perhaps the bug reporter could add details on how the binary was
built & run, maybe even include "-v" on the GHC command-line?

thx --sigbjorn

comment:2 Changed 8 years ago by sof

  • Resolution set to fixed
  • Status changed from new to closed

Now fixed; due to mismatches in gcc versions used when doing nightly builds.

Note: See TracTickets for help on using tickets.