#7089 closed bug (worksforme)

-fwarn-unused-do-bind with type families

Reported by: dag Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Incorrect warning at compile-time Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

When using acid-state, I get warnings for "unused do binds" from functions that return () but whose type involve asssociated types:

update :: UpdateEvent event => AcidState (EventState event) -> event -> IO (EventResult event)

Shouldn't GHC be able to deduce when EventResult resolves to unit?

Change History (4)

comment:1 Changed 21 months ago by dag

  • Type of failure changed from None/Unknown to Incorrect warning at compile-time

comment:2 Changed 21 months ago by simonpj

  • Difficulty set to Unknown

Perhpas you can give a small standalone reproducible test case?

comment:3 Changed 21 months ago by dag

I'm unable to reproduce this without acid-state, so something more complicated is going on. Investigating.

comment:4 Changed 18 months ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

As we have no way to reproduce this, I'm closing it. Please reopen (or open a new ticket) if you find a way to reproduce it.

Note: See TracTickets for help on using tickets.