#7018 closed feature request (invalid)

Preprocess code before checking safety

Reported by: favonia Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: GHC rejects valid program Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Apparently GHC checks safety (as safe Haskell) before preprocessing. This is sometimes undesirable; for example:

#if __GLASGOW_HASKELL__ >= 702
import Foreign.Safe
#else
import Foreign
#endif

Not sure if preprocessing will break the design of safe Haskell, but if it won't I hope GHC can accept this code as safe.

Change History (1)

comment:1 Changed 22 months ago by favonia

  • Resolution set to invalid
  • Status changed from new to closed

I am sorry but I cannot reproduce this error anymore. Perhaps I messed up something before.

Note: See TracTickets for help on using tickets.