Opened 8 years ago

Closed 8 years ago

#686 closed bug (worksforme)

warning: implicit declaration of function `ftruncate'

Reported by: simonmar Owned by: simonmar
Priority: normal Milestone: 6.4.2
Component: libraries/base Version: 6.5
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Reported by Conal Elliot. might be caused by a new mingw version, we haven't looked into it yet.


With ghc-6.5.20060106-i386-unknown-mingw32.tar.gz, I'm getting the following warnings when I compile with -O:

  [ 3 of 40] Compiling Pajama.TreeToGraph ( Pajama/TreeToGraph.hs, Pajama/TreeToGraph.o )
  In file included from c:/tmp/ghc200508_0.hc:4: 
  c:/ghc/ghc-6.5/include/HsBase.h: In function `__hscore_ftruncate':
  c:/ghc/ghc-6.5/include/HsBase.h:402: warning: implicit declaration of function `ftruncate'

and so on for every module. Same messages from 20060103.

Change History (1)

comment:1 Changed 8 years ago by simonmar

  • Resolution set to worksforme
  • Status changed from new to closed

Can't repeat this with a newly downloaded mingw, so I'm assuming it was a temporary wibble.

Note: See TracTickets for help on using tickets.