#6143 closed bug (fixed)

Regression: lots of documentation missing

Reported by: simonmar Owned by: pcapriotti
Priority: highest Milestone: 7.6.1
Component: Documentation Version: 7.5
Keywords: Cc: mihai.maruseac@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Something is wrong with the Haddock docs in the HEAD, such that most (but not all) functions have no documentation. Just point your browser at libraries/base/dist-install/doc/html/base/Prelude.html in a validate build, and you'll see that many functions are missing documentation. The first one I see on that page is otherwise.

Attachments (1)

6143.patch (1.1 KB) - added by pcapriotti 22 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 22 months ago by mihai.maruseac

  • Cc mihai.maruseac@… added

comment:2 Changed 22 months ago by pcapriotti

  • Owner set to pcapriotti

Changed 22 months ago by pcapriotti

comment:3 Changed 22 months ago by pcapriotti

  • Status changed from new to patch

This is caused by a bug in haddock, which stopped showing the documentation for re-exported declarations. The attached patch fixes it.

I think I traced the problem back to commit 60a043541e062ff6ceb52b0ab9e4f67d79dd3754.

comment:4 Changed 22 months ago by pcapriotti

  • Resolution set to fixed
  • Status changed from patch to closed

Fixed by

commit 105f31e1b5b1428ae27590893740017327d322ff
Author: Paolo Capriotti <p.capriotti@gmail.com>
Date:   Fri Jun 22 18:26:47 2012 +0100

    Use right docMap to get decl documentation.
Note: See TracTickets for help on using tickets.