Opened 23 months ago

Last modified 8 weeks ago

#6138 new bug

GHCI Startup Crash with HP 2012.2.0.0 on 64bit OS X 10.6

Reported by: MtnViewMark Owned by:
Priority: normal Milestone:
Component: Runtime System Version: 7.6.1
Keywords: Cc: sebastian.redl@…, simonmar
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: GHCi crash Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

This is a migration of HP ticket #199:

Installation of the HP appears to have succeeded and things seem to compile and work fine, but GHCI frequently crashes on startup. Here:

GHCi, version 7.4.1: http://www.haskell.org/ghc/ :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Segmentation fault

There's a 2-3 second delay between the last message and the segfault. Trying to invoke GHCI a couple of times eventually succeeds and results in a working REPL. I have reproduced this on two machines that ran the previous version just fine.

Please see the attached crash reporter log in the original ticket: The crash appears to be in the garbage collector.

Change History (2)

comment:1 Changed 23 months ago by igloo

  • Difficulty set to Unknown
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the report, but I think XCode 3.2.6 is too old. http://www.haskell.org/ghc/download_ghc_7_4_1#macosx_x86_64 says you need 4.1 to use our binaries.

comment:2 Changed 8 weeks ago by CornedBee

  • Cc sebastian.redl@… simonmar added
  • Resolution wontfix deleted
  • Status changed from closed to new
  • Type of failure changed from None/Unknown to GHCi crash
  • Version changed from 7.4.1 to 7.6.1

So I installed GHC 7.6.3 (which is missing from the version field below, btw) and XCode 4.2 (the newest thing available for OSX 10.6.8), and I'm observing the same intermittent crash. 64-bit version.

So either 7.6 needs an even newer XCode than 7.4 (why?) and the website needs another update, or the issue is not with an old XCode; instead it's with 10.6 in general. Which would be a real pity.

Note: See TracTickets for help on using tickets.