#6125 closed bug (worksforme)

GHCi crash

Reported by: guest Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.0.3
Keywords: Cc:
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: GHCi crash Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I received the following message about a crash while running ghci. I'm definitely doing some things I should not be, but this was also not expected; I'm not sure if it's something that should be fixed or if this is a case of "don't do that". Namely, I'm starting a Google App Engine dev_appserver.py script using System.Process.runCommand. The trouble is, I can't install the latest process package on my Windows system, so I'm stuck with some outdated commands - I can't terminate a process group on Windows, so I use terminateProcess to just kill the top process created, then terminate the underlying python.exe through Task Manager.

You can see where I tried to reload my .hs below after killing python.exe; I was trying to type ":r". I'm not sure if this is related, or just the issue with running/exiting App Engine. The crash may be related to the fact that I'm using the ghci standard output for the App Engine process (somehow, it trapped the ":" in my command even after I killed python.exe, but before typing anything else). I did manually ping the local App Engine server after terminating the top process, but before killing python.exe - I noticed the output was redirected to ghci. This may just be a strange issue with how App Engine traps messages.

*Main> r

<interactive>:1:1: Not in scope: `r'
*Main>
ghc.exe: panic! (the 'impossible' happened)

(GHC version 7.0.3 for i386-unknown-mingw32):

thread blocked indefinitely in an MVar operation

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

Change History (3)

comment:1 Changed 23 months ago by guest

  • Architecture changed from Unknown/Multiple to x86_64 (amd64)
  • Component changed from Compiler to GHCi
  • Operating System changed from Unknown/Multiple to Windows
  • Type of failure changed from None/Unknown to GHCi crash

comment:2 Changed 23 months ago by guest

(I'm not OP) This might be a duplicate of #4245.

comment:3 Changed 23 months ago by simonmar

  • Difficulty set to Unknown
  • Resolution set to worksforme
  • Status changed from new to closed

either #4245 or #5588, I expect. Please try with a more recent version of GHC and reopen the ticket if the bug still happens.

Note: See TracTickets for help on using tickets.