Opened 2 years ago

Closed 2 years ago

#6116 closed bug (fixed)

ctrl-c doesn't always work when entering text in ghci

Reported by: judahj Owned by:
Priority: high Milestone: 7.6.1
Component: GHCi Version: 7.5
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Incorrect result at runtime Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

With ghci-7.5.20120519 (on Mac and probably also Linux): type some text, then press ctrl-c. Then type more text, and press ctrl-c again. The first time you press ctrl-c, it starts a new line. But the second time you press ctrl-c, nothing happens. (Actually running code from within ghci resets this process.)

This is a regression from the behavior of ghci-7.4.1, where every time you press ctrl-C it caused a new line to be printed.

From my initial investigation, I think this was caused by ghc commit 206c8fc3ebd64c40ae09742fdea09ffd0f915d5c, which was used to fix #2786.

Change History (3)

comment:1 Changed 2 years ago by simonmar

  • Component changed from Compiler to GHCi
  • Difficulty set to Unknown
  • Milestone set to 7.6.1
  • Priority changed from normal to high

Thanks for the report, I'll look into it.

comment:2 Changed 2 years ago by marlowsd@…

commit 4b523bc139a05a52a58811623d638c43d398f245

Author: Simon Marlow <marlowsd@gmail.com>
Date:   Tue May 22 11:39:03 2012 +0100

    Don't remove the thread from interruptTargetThread on ^C (#6116)

 compiler/utils/Panic.lhs |   33 ++++++++++++++++++---------------
 1 files changed, 18 insertions(+), 15 deletions(-)

comment:3 Changed 2 years ago by simonmar

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.