Opened 2 years ago

Closed 2 years ago

#6105 closed bug (fixed)

GHCi does no respect -fforce-recomp

Reported by: SimonHengel Owned by: simonmar
Priority: high Milestone: 7.4.2
Component: GHCi Version: 7.4.1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

To my delightful surprise ghc --make respects -fforce-recomp, when given in a source file with OPTIONS_GHC.

But GHCi does not respect it.

Steps to reproduce:

-- file Bar.hs
{-# OPTIONS_GHC -fforce-recomp #-}
module Bar where
$ ghci Bar.hs
*Bar> :reload

Expected result: Bar.hs is recompiled on :reload

Actual result: Nothing is recompiled on :reload

Change History (4)

comment:1 Changed 2 years ago by simonmar

  • Difficulty set to Unknown
  • Milestone set to 7.4.2
  • Owner set to simonmar
  • Priority changed from normal to high

I know what the problem is here. Thanks for the report.

comment:2 Changed 2 years ago by marlowsd@…

commit c95342cef63fad2edfaf3868de11ff7781b440c8

Author: Simon Marlow <marlowsd@gmail.com>
Date:   Tue May 22 12:30:36 2012 +0100

    checkStability: respect -fforce-recomp (#6105)

 compiler/main/GhcMake.hs |    6 ++++--
 1 files changed, 4 insertions(+), 2 deletions(-)

comment:3 Changed 2 years ago by simonmar

  • Status changed from new to merge

comment:4 Changed 2 years ago by pcapriotti

  • Resolution set to fixed
  • Status changed from merge to closed
Note: See TracTickets for help on using tickets.