Opened 3 years ago

Closed 3 years ago

#6085 closed bug (invalid)

I found that it cannot be written such as [False..]

Reported by: phi16 Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: GHC rejects valid program Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):


Please see the following results:

Prelude> [False..] <interactive>:0:9: parse error on input ']'

I think this is a bug.

It occurred when compiling with GHC, too. and, It occurred when I tried to write "[LT..]","[True..]"

It didn't occurred when I put a space after "False" and, It didn't occurred when I tried to write "[()..]", either

Please check this problem.

I can't write English. I generated these sentence with Google Translate. I'm sorry that these English is poor...

Change History (1)

comment:1 Changed 3 years ago by simonpj

  • difficulty set to Unknown
  • Resolution set to invalid
  • Status changed from new to closed

The trouble is that "False.." is being lexed as a qualified name. You have to write [False ..] with a space.

See We tried to put this change in Haskell Prime but it was rejected so we backed off.

Note: See TracTickets for help on using tickets.