Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6053 closed bug (invalid)

packages in GHC should have different versions from hackage if the packages differ

Reported by: Lemming Owned by:
Priority: normal Milestone:
Component: libraries/unix Version: 7.5
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


I try to compile a package with many dependencies using GHC-7.5.20120426 in order to check whether #5970 is resolved. This turns out to be difficult because this temporary GHC version seems to use packages with the same version as their counterparts on Hackage but different content.

For example GHC-7.5.20120426 is bundled with unix- and bytestring- However the unix- on Hackage excludes bytestring- Thus cabal-install refuses to install something that depends on unix-

Another example: Both GHC-7.4.1 and GHC-7.5.20120426 are bundled with base- However in GHC-7.5, Num is no longer superclass of Bits. I think such a change requires a version bump to base-4.6.

Change History (2)

comment:1 Changed 5 years ago by igloo

difficulty: Unknown
Resolution: invalid
Status: newclosed

Currently we don't generally bump package versions in the repositories until we're doing a release.

If we want to change that policy, then we should discuss it on one of the mailing lists - a ticket isn't a good place to have that sort of discussion.

comment:2 Changed 5 years ago by simonmar

I definitely think we should change the policy - in fact I typically bump a library as soon as I change it, to avoid this problem. Is the policy written down anywhere? It wouldn't be hard to change, right?

Note: See TracTickets for help on using tickets.