Opened 3 years ago

Closed 3 years ago

#6033 closed bug (duplicate)

Could not install hmatrix, windows 7

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

C:\Users\Артур>cabal install hmatrix
Resolving dependencies...
Configuring vector-0.9.1...
Preprocessing library vector-0.9.1...
Building vector-0.9.1...
[ 1 of 30] Compiling Data.Vector.Storable.Internal ( Data\Vector\Storable\Intern
al.hs, dist\build\Data\Vector\Storable\Internal.o )
[ 2 of 30] Compiling Data.Vector.Fusion.Util ( Data\Vector\Fusion\Util.hs, dist\
build\Data\Vector\Fusion\Util.o )
[ 3 of 30] Compiling Data.Vector.Fusion.Stream.Size ( Data\Vector\Fusion\Stream\
Size.hs, dist\build\Data\Vector\Fusion\Stream\Size.o )

Data\Vector\Fusion\Stream\Size.hs:30:10:

Warning: No explicit method nor default method for `*'
In the instance declaration for `Num Size'

Data\Vector\Fusion\Stream\Size.hs:30:10:

Warning: No explicit method nor default method for `abs'
In the instance declaration for `Num Size'

Data\Vector\Fusion\Stream\Size.hs:30:10:

Warning: No explicit method nor default method for `signum'
In the instance declaration for `Num Size'

[ 4 of 30] Compiling Data.Vector.Internal.Check ( Data\Vector\Internal\Check.hs,

dist\build\Data\Vector\Internal\Check.o )

[ 5 of 30] Compiling Data.Vector.Fusion.Stream.Monadic ( Data\Vector\Fusion\Stre
am\Monadic.hs, dist\build\Data\Vector\Fusion\Stream\Monadic.o )
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Loading package primitive-0.4.1 ... ghc.exe: panic! (the 'impossible' happened)

(GHC version 7.0.4 for i386-unknown-mingw32):

loadObj "C:
Users
\1040\1088\1090\1091\1088
AppData
Roaming
cabal

primitive-0.4.1
ghc-7.0.4
HSprimitive-0.4.1.o": failed

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

cabal: Error: some packages failed to install:
hmatrix-0.14.0.1 depends on vector-0.9.1 which failed to install.
vector-0.9.1 failed during the building phase. The exception was:
ExitFailure 1

Change History (2)

comment:1 Changed 3 years ago by guest

  • Summary changed from Could not intall hmatrix, windows 7 to Could not install hmatrix, windows 7

comment:2 Changed 3 years ago by simonmar

  • difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

Fixed in 7.4.1: #5697

Note: See TracTickets for help on using tickets.