Opened 3 years ago

Closed 3 years ago

#6029 closed bug (duplicate)

GHC fails to stop at phase HCc

Reported by: liuexp Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Other Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I tried with several different haskell source code and all got the same error:

[liuexp@liuexp pearls]$ ghc -C minfree.hs

addFlag by -C on the commandline:

Warning: The -fvia-C flag does nothing; it will be removed in a future GHC release

ghc: panic! (the 'impossible' happened)

(GHC version 7.4.1 for i386-unknown-linux):

pipeLoop: at phase As but I wanted to stop at phase HCc

here's minfree.hs for reference:

[liuexp@liuexp pearls]$ cat minfree.hs {-# OPTIONS_GHC -O2 #-} module Pearls where import Data.List hiding (union) import Data.List.Ordered (minus,union) import Data.Map (Map) import Data.Set (Set) import qualified Data.Set as DS import qualified Data.Map as DM import Data.Sequence (Seq, (<|), (|>), (><)) import qualified Data.Sequence as S import qualified Data.Foldable as F

import Control.Monad import Control.Applicative

--assuming no duplicates minfree xs = minfrom 0 (length xs,xs) minfrom a (n,xs)

|n == 0 = a |m == b -a = minfrom b (n-m,vs) |otherwise = minfrom a (m,us) where (us,vs)= partition (<b) xs

b = a + 1 + n div 2 m = length us

Attachments (1)

minfree.hs (622 bytes) - added by liuexp 3 years ago.
minfree.hs to reproduce the bug

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by liuexp

minfree.hs to reproduce the bug

comment:1 Changed 3 years ago by liuexp

looks like the source code messed up, I attached a file instead.

comment:2 Changed 3 years ago by michalt

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for reporting. This seems to be a duplicate of #5582, which is already fixed. :)

Note: See TracTickets for help on using tickets.