Opened 2 years ago

Closed 19 months ago

#5953 closed bug (wontfix)

Program execution fails with runtime error.

Reported by: J.Hage@… Owned by:
Priority: normal Milestone:
Component: Runtime System Version: 7.0.3
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: Runtime crash Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

I ran a very memory consuming program on a 32GB machine
with the following RTS arguments:

-H18000M -S -c

hoping that I could avoid all the copying.
However, I got the following message:

internal error: update_fwd: unknown/strange object  27330425
    (GHC version 7.0.3 for x86_64_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Abort

As a side note: with just the -c option, I had run into
a Segmentation Fault.

Without any run-time options, the programs fails to complete
succesfully before running out of memory.

Change History (5)

comment:1 Changed 2 years ago by simonmar

  • Difficulty set to Unknown
  • Status changed from new to infoneeded

I think it might be this bug: #5644, which was fixed in 7.4.1.

Could you try with 7.4.1 and see if the problem goes away please?

comment:2 Changed 2 years ago by J.Hage@…

I would like to, but on this Linux server I have no rights whatsoever. They can't even tell me how long it will take to install a profiled version of 7.0.3.

I could try to see if my Mac has the same issue, and then see if using 7.4.1 solves it.
But that will take some doing.

Jur

comment:3 Changed 2 years ago by J.Hage@…

Some more information for you:

  • it seems that the options I had
    -H18000M -S -c
    
    are necessary to get an internal error. With 2000M or without -S I get a segmentation fault, but that is all.
  • On my Mac (also ghc 7.0.3) I simply get an out of memory error when I used -H2000M (can't allocate this and that),
    asli: memory allocation failed (requested 2097152 bytes)

and I can't run the application when I set -H18000
because it is outside allowed range.

Any more things I can try?

Jur

comment:4 Changed 19 months ago by igloo

  • Description modified (diff)

comment:5 Changed 19 months ago by igloo

  • Resolution set to wontfix
  • Status changed from infoneeded to closed

I'm afraid there's really not much we can do without a way to reproduce this with a recent GHC. Please open another ticket with a testcase if you still have problems with 7.6.1.

Note: See TracTickets for help on using tickets.