Opened 2 years ago

Closed 7 months ago

#5889 closed bug (fixed)

-fno-prof-count-entries leads to linking errors

Reported by: akio Owned by:
Priority: normal Milestone: 7.6.2
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: GHC rejects valid program Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

When I compile the attached program with a certain set of flags, I get a linking error.

% ghc -O -prof -fprof-auto -fno-prof-count-entries -fforce-recomp main.hs                           
[1 of 2] Compiling Foo              ( Foo.hs, Foo.o )
[2 of 2] Compiling Main             ( main.hs, main.o )
Linking main ...
main.o: In function `s1uR_info':
(.text+0xcc): undefined reference to `Foo_makePairzitotal_C0_cc'
collect2: ld returned 1 exit status

Attachments (2)

main.hs (140 bytes) - added by akio 2 years ago.
main.hs
Foo.hs (265 bytes) - added by akio 2 years ago.
Foo.hs

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by akio

main.hs

Changed 2 years ago by akio

Foo.hs

comment:1 Changed 22 months ago by pcapriotti

  • Difficulty set to Unknown
  • Milestone set to 7.6.1

Thanks for the report.

comment:2 Changed 19 months ago by igloo

  • Milestone changed from 7.6.1 to 7.6.2

comment:3 Changed 7 months ago by akio

  • Resolution set to fixed
  • Status changed from new to closed

I cannot reproduce this error with GHC 7.6.2.

Note: See TracTickets for help on using tickets.