Opened 13 years ago

Closed 13 years ago

Last modified 44 years ago

#586 closed bug (Duplicate)

GHCi: missing .hs gives unhelpful msg

Reported by: magunter Owned by: nobody
Priority: normal Milestone:
Component: Compiler Version: 5.0
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Trying to load a module (via an import chain) for
which the .hs does not exist results in the
following message:

   *** Exception: does not exist
  Action: withFileStatus
  Reason: No such file or directory
  Prelude> 

It took me a while to figure out what was going on.
It would have helped tremendously to know what
file was missing.

It might be best to treat a missing .hs as an
infinitely old .hs (perhaps with an indication that
it is missing.)

(The missing .hs resulted from the writing the
make rules for creating a library including GreenCard
code in the straightforward way.)

     mike

Change History (2)

comment:1 Changed 13 years ago by magunter

Logged In: YES 
user_id=300931

It appears this is a duplicate of 453587.  Sorry.

   mike


comment:2 Changed 13 years ago by simonmar

  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.