Opened 2 years ago

Closed 17 months ago

#5831 closed bug (worksforme)

space_leak_001(ghci) segfaults on OS X x86_64

Reported by: igloo Owned by:
Priority: high Milestone: 7.6.2
Component: Compiler Version: 7.5
Keywords: Cc:
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

In 7.4 branch and HEAD, space_leak_001(ghci) segfaults on OS X x86_64.

I can reproduce it most of the time like this (with GhcDebugged=YES, GhcThreaded=NO):

$ time /Users/ian/ghc/7.4-branch/val64/inplace/bin/ghc-stage2 --interactive space_leak_001.hs +RTS -DS -C0 -V0
created capset 0 of type 2
created capset 1 of type 3
assigned cap 0 to capset 0
assigned cap 0 to capset 1
GHCi, version 7.4.0.20120126: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
[1 of 1] Compiling Main             ( space_leak_001.hs, interpreted )
Ok, modules loaded: Main.
*Main> main
Segmentation fault: 11

real    6m11.094s
user    6m7.249s
sys     0m0.195s

but if I run it under gdb then it doesn't segfault.

Change History (8)

comment:1 Changed 2 years ago by igloo

  • Architecture changed from Unknown/Multiple to x86_64 (amd64)
  • Operating System changed from Unknown/Multiple to MacOS X

Can't reproduce it on OX X i386.

comment:2 Changed 21 months ago by luite

The patch I submitted for #7040 also fixes this crash on my system (OS X 10.8 x86_64)

comment:3 Changed 20 months ago by simonmar

  • Owner set to simonmar

I'm testing the #7040 patch, so I'll look at this too.

comment:4 Changed 19 months ago by igloo

  • Milestone changed from 7.6.1 to 7.6.2

comment:5 Changed 18 months ago by simonmar

  • Milestone changed from 7.6.2 to 7.6.1
  • Owner simonmar deleted

Could someone with a Mac test this please?

comment:6 Changed 18 months ago by simonmar

  • Milestone changed from 7.6.1 to 7.6.2

(revert accidental milestone change)

comment:7 Changed 18 months ago by igloo

~/ghc/git/val64/testsuite/tests/perf/space_leaks$ time ../../../../inplace/bin/ghc-stage2 --interactive space_leak_001.hs 
GHCi, version 7.7.20121021: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer-simple ... linking ... done.
Loading package base ... linking ... done.
[1 of 1] Compiling Main             ( space_leak_001.hs, interpreted )
Ok, modules loaded: Main.
*Main> main
Segmentation fault: 11

real    24m57.682s
user    24m42.456s
sys     0m11.225s

("Dynamic by default" is "NO"; this build happened to be using integer-simple, but I assume that that just made it take longer)

comment:8 Changed 17 months ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

I was going to test whether dynamic-by-default fixed this, but now I can't reproduce it all. I'll close the ticket, but if the problem re-emerges I'll look into it.

Note: See TracTickets for help on using tickets.