Opened 14 years ago

Closed 14 years ago

Last modified 46 years ago

#577 closed bug (Fixed)

Directory.renameFile fails on symlinks

Reported by: magunter Owned by: nobody
Priority: normal Milestone:
Component: None Version: 5.0
Keywords: Cc:
Operating System: Architecture:
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

renameFile fails on symbolic links when I believe it
shouldn't.  The problem is that it uses
withFileStatus which uses stat(2) instead of
lstat(2).  As a result it fails when trying to
rename a link which points nowhere and (presumably
-- I haven't tested this) or a link to a directory.

BTW, I was surprised to not find a "standard library"
bug category.

Change History (1)

comment:1 Changed 14 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

Fixed, thanks.
Note: See TracTickets for help on using tickets.