Opened 2 years ago

Closed 2 years ago

#5703 closed bug (duplicate)

vector fails to compile due to simplifier ticks exhausted

Reported by: tibbe Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I thought the limit was raised in 7.4 but vector still fails to compile using the current ghc-7.4 branch:

Configuring vector-algorithms-0.5.3...
Preprocessing library vector-algorithms-0.5.3...
Building vector-algorithms-0.5.3...
[1 of 9] Compiling Data.Vector.Algorithms.Common ( Data/Vector/Algorithms/Common.hs, dist/build/Data/Vector/Algorithms/Common.o )
[2 of 9] Compiling Data.Vector.Algorithms.Radix ( Data/Vector/Algorithms/Radix.hs, dist/build/Data/Vector/Algorithms/Radix.o )
[3 of 9] Compiling Data.Vector.Algorithms.Search ( Data/Vector/Algorithms/Search.hs, dist/build/Data/Vector/Algorithms/Search.o )
[4 of 9] Compiling Data.Vector.Algorithms.Optimal ( Data/Vector/Algorithms/Optimal.hs, dist/build/Data/Vector/Algorithms/Optimal.o )
[5 of 9] Compiling Data.Vector.Algorithms.Insertion ( Data/Vector/Algorithms/Insertion.hs, dist/build/Data/Vector/Algorithms/Insertion.o )
[6 of 9] Compiling Data.Vector.Algorithms.AmericanFlag ( Data/Vector/Algorithms/AmericanFlag.hs, dist/build/Data/Vector/Algorithms/AmericanFlag.o )
[7 of 9] Compiling Data.Vector.Algorithms.Heap ( Data/Vector/Algorithms/Heap.hs, dist/build/Data/Vector/Algorithms/Heap.o )
[8 of 9] Compiling Data.Vector.Algorithms.Intro ( Data/Vector/Algorithms/Intro.hs, dist/build/Data/Vector/Algorithms/Intro.o )
ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 7.4.0.20111213 for x86_64-apple-darwin):
	Simplifier ticks exhausted
    When trying UnfoldingDone ( ghc-prim:GHC.Classes.||{v r1c} [gid] :: ghc-prim:GHC.Types.Bool{(w) tc 3c}
                                                                        -> ghc-prim:GHC.Types.Bool{(w) tc 3c}
                                                                        -> ghc-prim:GHC.Types.Bool{(w) tc 3c} )
    To increase the limit, use -fsimpl-tick-factor=N (default 100)
    If you need to do this, let GHC HQ know, and what factor you needed
    To see detailed counts use -ddump-simpl-stats
    Total ticks: 46921

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (1)

comment:1 Changed 2 years ago by tibbe

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5539

Note: See TracTickets for help on using tickets.