Opened 2 years ago

Closed 2 years ago

#5675 closed bug (fixed)

OperationalError: database is locked

Reported by: erikd Owned by:
Priority: normal Milestone:
Component: None Version: 7.2.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

How to Reproduce

While doing a POST operation on /ticket/5673, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'144976e071988a4e226a3e62',
 'action': u'leave',
 'cnum': u'3',
 'comment': u"I agree with momeata.\r\n\r\nMy main problem with this is the element of surprise; the main function works correctly while calling newlineCount doesn't.\r\n\r\nEven Haskell beginners are being told that in most cases ByteString or Text should be chosen over String. They are also encouraged to try things out in GHCi. This behavior will confound and confuse them. It certainly did that for me and I've although I'm not anywhere near a Haskell expert I have been using Haskell for many years.",
 'field_architecture': u'Unknown/Multiple',
 'field_blockedby': u'',
 'field_blocking': u'',
 'field_component': u'GHCi',
 'field_failure': u'Other',
 'field_keywords': u'',
 'field_os': u'Unknown/Multiple',
 'field_summary': u'GHCi ignores {-# LANGUAGE OverloadedStrings #-}',
 'field_testcase': u'',
 'field_type': u'bug',
 'field_version': u'7.0.4',
 'id': u'5673',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2011-12-03 18:31:46+00:00'}

User Agent was: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0 Iceweasel/8.0

System Information

Trac 0.11.6
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
setuptools 0.6c8
SQLite 3.5.9
pysqlite 2.3.2
Genshi 0.5.1
mod_python 3.3.1
Pygments 0.10
GIT 1.5.6.5
FullBlog? 0.1.1
RPC 1.0.6
CustomFieldAdmin? 0.2.2
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/trac/ticket/web_ui.py", line 182, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.5/site-packages/trac/ticket/web_ui.py", line 508, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/lib/python2.5/site-packages/trac/ticket/web_ui.py", line 1022, in _do_save
    cnum=internal_cnum):
  File "/usr/lib/python2.5/site-packages/trac/ticket/model.py", line 284, in save_changes
    (self.id, when_ts, author, cnum, comment))
  File "/usr/lib/python2.5/site-packages/trac/db/util.py", line 64, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 80, in execute
    PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 59, in execute
    args or [])
  File "/usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 51, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (1)

comment:1 Changed 2 years ago by erikd

  • Resolution set to fixed
  • Status changed from new to closed

Seems to be working now. Closing this bug.

Note: See TracTickets for help on using tickets.