Opened 2 years ago

Closed 2 years ago

#5662 closed bug (duplicate)

GHCi crashes in context of banana bracket in arrow notation

Reported by: Duschvorhang Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.0.3
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: GHCi crash Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Loading the attached haskell file in GHCi results in the following message. Compiling with ghc however is successful.

ghc.exe: panic! (the 'impossible' happened)

(GHC version 7.0.3 for i386-unknown-mingw32):

addTickHsExpr

(|/\(@ a{tv ayK} [sk]).

(arrows-0.4.4.0:Control.Arrow.Transformer.State.runState{v rgG} [gid])
@ arr{tv ayH} [sk]
@ ghc-prim:GHC.Types.Int{(w) tc 3J}
@ a{tv ayK} [sk]
@ ghc-prim:GHC.Types.Int{(w) tc 3J}

$dArrow{v aCr} [lid]
(((main:Main.goodArrow{v rp6} [lid])

@ (arrows-0.4.4.0:Control.Arrow.Transformer.State.StateArrow{tc rgD}

ghc-prim:GHC.Types.Int{(w) tc 3J} arr{tv ayH} [sk])

$dArrowState{v aCs} [lid] -< b{v apd} [lid]))|)

Attachments (1)

Ticket 5662.hs (423 bytes) - added by Duschvorhang 2 years ago.

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by Duschvorhang

comment:1 Changed 2 years ago by michalt

Works for me (both on 7.2.2 and HEAD). Isn't this a duplicate of #5045?

comment:2 Changed 2 years ago by simonmar

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like it, thanks.

Note: See TracTickets for help on using tickets.