Opened 14 years ago

Closed 14 years ago

Last modified 46 years ago

#562 closed bug (Wont Fix)

panic! (impossible happened) 5.0.2/RH6.2

Reported by: tmoertel Owned by: nobody
Priority: normal Milestone:
Component: Compiler Version: 5.0
Keywords: Cc:
Operating System: Architecture:
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):


Recipe to replicate:

0. Install ghc-5.00.2 binary RPM on Red Hat Linux 6.2.

1. Download and untar the raytracer that Galois 
Connections submitted to last year's ICFP programming 

2. Edit CSG/Makefile, adding "lang" to the line 
reading "HC_PKG = " so that it reads "HC_PKG = lang".

3. At the project's root directory, "make".

4. Error occurs while compiling Parse.hs:

ghc-5.00.2: panic! (the `impossible' happened, GHC 
version 5.00.2):
    mk_ww_str: not a product ParsecError.SourceName{-

Change History (1)

comment:1 Changed 14 years ago by simonpj

  • Status changed from assigned to closed
Logged In: YES 

-funbox-strict-fields doesn't work on ghc5.00.2 (its in the 

Fixed in the head.
Note: See TracTickets for help on using tickets.