Opened 7 years ago

Closed 7 years ago

#5588 closed bug (fixed)

panic after pressing Ctrl+C in ghci

Reported by: MBoehm Owned by:
Priority: highest Milestone: 7.2.1
Component: GHCi Version: 7.0.3
Keywords: Cc: fliegenblues@…
Operating System: Windows Architecture: x86
Type of failure: GHCi crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Hello! I'm using GHCi 7.0.3 on Windows 7.

I found the following easy reproducible bug:

  1. Start ghci
  2. Hit Ctrl+C.
  3. Type something, e.g. abc, press enter
  4. ghci will crash with the error:

ghc.exe: panic! (the 'impossible' happened)

(GHC version 7.0.3 for i386-unknown-mingw32):

thread blocked indefinitely in an MVar operation

Regards, Matthias Böhm

Change History (5)

comment:1 Changed 7 years ago by MBoehm

Cc: fliegenblues@… added

I noticed that this seems to be the same bug as in #4245.

comment:2 Changed 7 years ago by simonmar

What shell are you using? cmd.exe, MSYS, Cygwin, something else? Anything else about your environment that might be relevant? I'm not able to reproduce the bug here.

comment:3 Changed 7 years ago by simonmar

No wait! I did manage to reproduce it, but I had to C a couple more times.

comment:4 Changed 7 years ago by simonmar

Milestone: 7.4.1
Priority: normalhighest

comment:5 Changed 7 years ago by simonmar

Milestone: 7.4.17.2.1
Resolution: fixed
Status: newclosed

I can reproduce this with 7.0.4, but not with 7.2.1 and later on Windows. So I think this bug has been fixed.

I suspect there are multiple bugs with similar symptoms in this area - at least one bug still remains (#4245).

Note: See TracTickets for help on using tickets.