Opened 3 years ago

Closed 3 years ago

#5519 closed bug (duplicate)

Some unicode symbols are not allow in literal characters or strings

Reported by: ertai Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.2.1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

main = putChar 'ₖ'

This program is rejected with following error message:
lexical error in string/character literal at character '\8342'

There is at least a few other characters with the same issue, for
instance this whole string should be accepted:
"ₕₖₗₘₙₒₚᵣₛₜᵤᵥₓ"

A related issue is that GHCi do not let me paste these characters either.

Change History (1)

comment:1 Changed 3 years ago by daniel.is.fischer

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5518

Note: See TracTickets for help on using tickets.