Opened 3 years ago

Closed 3 years ago

#5488 closed bug (duplicate)

GHC-7.2.1 standalone failed to bootstrap ghc-HEAD on windows

Reported by: btutt Owned by:
Priority: normal Milestone:
Component: Build System Version: 7.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Building GHC failed Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

AR_STAGE0 gets set to:
AR_STAGE0='D:/slave/stable/builder/tempbuild/build/inplace/mingw/bin/ar.exe'

by configure.ac

ghc --info spits out:

,("ar command","D:/slave/stable/builder/tempbuild/build/inplace/mingw/bin/ar.exe")

I'll try the latest Haskell platform installer next.

Haskell platform is 2011.2.0.1 which is ghc-7.0.2 and doesn't output the ar.exe line from --info.

I forced AR_STAGE0 to the inplace mingw/bin/ar.exe path via manually editing config.status.

CC_STAGE0 had a similar problem.
7.2.1 standalone printed:
$topdir/../mingw/bin/gcc.exe

which turned into: opdir../mingw/bin/gcc.exe while trying to ghc-cabal.exe configure libraries/Cabal/cabal

Forcing CC_STAGE0 to $$topdir/.... didn't help either.

So i fixed CC_STAGE0 to inplace/mingw/bin/gcc.exe. Now ghc-cabal is configuring away.

Change History (1)

comment:1 Changed 3 years ago by btutt

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket:5484.

Note: See TracTickets for help on using tickets.