Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5485 closed bug (fixed)

Build failure on powerpc-linux at compiler/stgSyn/CoreToStg.lhs line 188

Reported by: erikd Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.3
Keywords: Cc:
Operating System: Linux Architecture: powerpc
Type of failure: Building GHC failed Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Current GHC head fails to build on powerpc-linux:

WARNING: file compiler/stgSyn/CoreToStg.lhs line 222
GHC.Num.$dmnegate False True
ghc-stage1: panic! (the 'impossible' happened)
  (GHC version 7.3.20110913 for powerpc-unknown-linux):
        ASSERT failed! file compiler/stgSyn/CoreToStg.lhs line 188
base:GHC.Num.$dmnegate{v r7H} [gid]

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Resetting to the version before this one:

commit fdac48f3a955997f5f9caddf5e38105cd636a010
Author: Ian Lynagh <[email protected]>
Date:   Mon Sep 12 23:24:53 2011 +0100

and it builds.

Attachments (1)

dump-output.txt (203.5 KB) - added by erikd 3 years ago.
Requested dump output

Download all attachments as: .zip

Change History (12)

comment:1 Changed 3 years ago by simonpj

I know what is going on here. Stay tuned

comment:2 Changed 3 years ago by simonpj@…

commit eecd53bcdc307726fb4bb058f3da013b72386137

Author: Simon Peyton Jones <[email protected]>
Date:   Wed Sep 14 12:03:17 2011 +0100

    Fix integer stuff (fixes Trac #5485)
    
    In particular, use mkConApp when building the (S# i)
    constructors in CorePrep

 compiler/basicTypes/MkId.lhs    |    8 +---
 compiler/coreSyn/CorePrep.lhs   |   84 +++++++++++++++++++++------------------
 compiler/prelude/TysWiredIn.lhs |    4 +-
 3 files changed, 49 insertions(+), 47 deletions(-)

comment:3 Changed 3 years ago by simonpj

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 3 years ago by erikd

  • Resolution fixed deleted
  • Status changed from closed to new

Sorry, same problem as before. The latest commit is:

commit eecd53bcdc307726fb4bb058f3da013b72386137
Author: Simon Peyton Jones <[email protected]>
Date:   Wed Sep 14 12:03:17 2011 +0100

    Fix integer stuff (fixes Trac #5485)

and I did the full:

perl boot && ./configure && make

comment:5 Changed 3 years ago by simonpj

Did you make clean?

It builds clean for me. What module is failing to compile? Can you show the exact message?

Simon

comment:6 Changed 3 years ago by erikd

Sorry, I thought I had done 'make clean' first.

Just retried it using:

make clean && perl boot && ./configure && make

and I'm getting:

"inplace/bin/ghc-stage1"   -H64m -O0 -fasm    -package-name base-4.4.0.0 -hide-all-packages -i -ilibraries/base/. -ilibraries/base/dist-install/build -ilibraries/base/dist-install/build/autogen -Ilibraries/base/dist-install/build -Ilibraries/base/dist-install/build/autogen -Ilibraries/base/include   -optP-DOPTIMISE_INTEGER_GCD_LCM -optP-include -optPlibraries/base/dist-install/build/autogen/cabal_macros.h -package ghc-prim-0.2.0.0 -package integer-gmp-0.3.0.0 -package rts-1.0  -package-name base -XHaskell98 -XCPP -O0 -dcore-lint -no-user-package-conf -rtsopts     -odir libraries/base/dist-install/build -hidir libraries/base/dist-install/build -stubdir libraries/base/dist-install/build -hisuf hi -osuf  o -hcsuf hc -c libraries/base/./Data/Fixed.hs -o libraries/base/dist-install/build/Data/Fixed.o
WARNING: file compiler/stgSyn/CoreToStg.lhs line 222
$cresolution6_rGy False True
ghc-stage1: panic! (the 'impossible' happened)
  (GHC version 7.3.20110914 for powerpc-unknown-linux):
        ASSERT failed! file compiler/stgSyn/CoreToStg.lhs line 188
$cresolution6{v rGy} [gid]

comment:7 Changed 3 years ago by simonpj

I'm very puzzled. I can't reproduce this. You are compiling libraries with -O0 which is fine; I'm doing that too.

OK, so pls compile Data.Fixed with -ddump-simpl -ddump-prep and attach the output. You should be able to cut/paste the compiler invocation for compiling Data.Fixed from your log.

Thanks

S

Changed 3 years ago by erikd

Requested dump output

comment:8 Changed 3 years ago by erikd

Ok, pulled git head then did:

make clean && perl boot && ./configure && make

and confirmed it was failing. The ran:

"inplace/bin/ghc-stage1"  -ddump-simpl -ddump-prep   -H64m -O0 -fasm    -package-name base-4.4.0.0 -hide-all-packages -i -ilibraries/base/. -ilibraries/base/dist-install/build -ilibraries/base/dist-install/build/autogen -Ilibraries/base/dist-install/build -Ilibraries/base/dist-install/build/autogen -Ilibraries/base/include   -optP-DOPTIMISE_INTEGER_GCD_LCM -optP-include -optPlibraries/base/dist-install/build/autogen/cabal_macros.h -package ghc-prim-0.2.0.0 -package integer-gmp-0.3.0.0 -package rts-1.0  -package-name base -XHaskell98 -XCPP -O0 -dcore-lint -no-user-package-conf -rtsopts     -odir libraries/base/dist-install/build -hidir libraries/base/dist-install/build -stubdir libraries/base/dist-install/build -hisuf hi -osuf  o -hcsuf hc -c libraries/base/./Data/Fixed.hs -o libraries/base/dist-install/build/Data/Fixed.o 2>&1 > dump-output.txt

I'll attach the file dump-output.txt.

comment:9 Changed 3 years ago by simonpj@…

commit b215384ba29f2ab85bf4655881fb78ff1161c975

Author: Simon Peyton Jones <[email protected]>
Date:   Thu Sep 15 09:11:18 2011 +0100

    Hack: add noCafIdInfo to shiftIntegerL and friends
    
    It's a hack becuase we have no good reason to be sure that
    these functions don't have any CAFs.  We're working on
    something better, but this should fix the build (Trac #5485)

 compiler/basicTypes/MkId.lhs |   19 +++++++++++--------
 1 files changed, 11 insertions(+), 8 deletions(-)

comment:10 Changed 3 years ago by simonpj

  • Resolution set to fixed
  • Status changed from new to closed

OK now I claim it's fixed! Try now.

comment:11 Changed 3 years ago by erikd

Confirmed.

Note: See TracTickets for help on using tickets.