Opened 3 years ago

Closed 3 years ago

#5479 closed bug (duplicate)

The impossible happened!

Reported by: adityadennis Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.2.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Running my haskell script gives me the following error:

eliza.hs: eliza.hs: panic! (the 'impossible' happened)

(GHC version 7.0.3 for x86_64-apple-darwin):

linkBCO: >= 64k ptrs

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

I am on a Darwin x86_64 machine with OS X version 10.6.6. The script that crashed is attached. "ChatRules?" referenced in the script is a list of type [String, [String]]. The list was >20000 values.

Attachments (1)

eliza.hs (1.0 KB) - added by adityadennis 3 years ago.
The files that caused the crash

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by adityadennis

The files that caused the crash

comment:1 Changed 3 years ago by igloo

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. I'll close this ticket as it's a duplicate of #3867.

Note: See TracTickets for help on using tickets.