Opened 3 years ago

Closed 3 years ago

#5432 closed bug (invalid)

hp2ps bug with relative path names

Reported by: simonmar Owned by:
Priority: high Milestone: 7.4.1
Component: Profiling Version: 7.2.1
Keywords: Cc: dominic@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

dominic@steinitz.org reports on glasgow-haskell-users:

If I use profiling on windows with relative path names e.g. the first line in the .hp file is something like:

JOB "ScriptUsage.exe -t ..\FPF\TradeDesc\TradesTags.txt -f ..\out\FPOs -u ..\Data\LogStarted090511c +RTS -H256M -hc"

then hp2ps produces nonsense.

If I replace this line with:

JOB "ScriptUsage.exe +RTS -H256M -hc"

then it works.

Is this a known bug or should I try to raise one?

Thanks, Dominic.

Attachments (1)

ScriptUsage.hp (103.9 KB) - added by dominic 3 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 3 years ago by igloo

  • Cc dominic@… added

I can't reproduce this on Linux. What command are you running? What do you mean by "nonsense"? Can you attach a complete .hp file showing the problem please?

Changed 3 years ago by dominic

comment:2 Changed 3 years ago by dominic

  • Resolution set to invalid
  • Status changed from new to closed

I can no longer reproduce the problem on Windows either. I have set the ticket status to invalid.

Note: See TracTickets for help on using tickets.