Opened 3 years ago

Closed 3 years ago

#5301 closed bug (worksforme)

Trac failure: "KeyError: 'fields'"

Reported by: modchan Owned by:
Priority: normal Milestone:
Component: None Version: 7.0.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

How to Reproduce

While doing a GET operation on /ticket/4000, Trac issued an internal error.

Request parameters:

{'action': u'diff', 'id': u'4000', 'version': u'3'}

User Agent was: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

System Information

Trac 0.11.6
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
setuptools 0.6c8
SQLite 3.5.9
pysqlite 2.3.2
Genshi 0.5.1
mod_python 3.3.1
Pygments 0.10
GIT 1.5.6.5
FullBlog? 0.1.1
RPC 1.0.6
CustomFieldAdmin? 0.2.2
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 217, in dispatch
    self._post_process_request(req, *resp)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 309, in _post_process_request
    resp = f.post_process_request(req, *resp)
  File "build/bdist.linux-x86_64/egg/mastertickets/web_ui.py", line 64, in post_process_request
    for field, field_data in change['fields'].iteritems():
KeyError: 'fields'


Change History (1)

comment:1 Changed 3 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the report. However, I can't reproduce it. If it happens again let us know, and I'll take a closer look.

Note: See TracTickets for help on using tickets.