Opened 4 years ago

Closed 4 years ago

#5276 closed bug (fixed)

Multithreaded build failure

Reported by: Owned by: benl
Priority: normal Milestone:
Component: Build System Version: 7.1
Keywords: Cc:
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


Building HEAD via sh validate fails with

"inplace/bin/ghc-stage2"   -H32m -O -Wall -Werror -H64m -O0    -package-name dph-seq-0.5 -hide-all-packages -i -ilibraries/dph/dph-seq/../dph-common -ilibraries/dph/dph-seq/dist-install/build -ilibraries/dph/dph-seq/dist-install/build/autogen -Ilibraries/dph/dph-seq/dist-install/build -Ilibraries/dph/dph-seq/dist-install/build/autogen -Ilibraries/dph/dph-seq/.    -optP-include -optPlibraries/dph/dph-seq/dist-install/build/autogen/cabal_macros.h -package array- -package base- -package dph-base-0.5 -package dph-prim-seq-0.5 -package ghc-7.1.20110624 -package ghc-prim- -package random- -package template-haskell-  -Odph -funbox-strict-fields -fcpr-off -fdph-this -package-name dph-seq -XHaskell98 -XTypeFamilies -XGADTs -XRankNTypes -XBangPatterns -XMagicHash -XUnboxedTuples -XTypeOperators -O2 -O -dcore-lint -fno-warn-deprecated-flags -no-user-package-conf -rtsopts -Wwarn    -odir libraries/dph/dph-seq/dist-install/build -hidir libraries/dph/dph-seq/dist-install/build -stubdir libraries/dph/dph-seq/dist-install/build -hisuf hi -osuf  o -hcsuf hc -c libraries/dph/dph-seq/../dph-common/Data/Array/Parallel/PArray/PData.hs -o libraries/dph/dph-seq/dist-install/build/Data/Array/Parallel/PArray/PData.o
Loading package ghc-prim ... linking ... done.
Loading package dph-base-0.5 ... linking ... done.
Loading package dph-prim-interface-0.5 ... linking ... done.
Loading package dph-prim-seq-0.5 ... <command line>: can't load .so/.DLL for: HSdph-prim-seq-0.5 ( cannot open shared object file: No such file or directory)
gmake[1]: *** [libraries/dph/dph-seq/dist-install/build/Data/Array/Parallel/PArray/PData.o] Fehler 1
gmake[1]: *** Warte auf noch nicht beendete Prozesse...
gmake: *** [all] Fehler 2

The build goes through when I invoke THREADS=1 sh validate, but it also fails when I specify THREADS=2. The build always fails at the same place, with the same error, it seems that with multiple threads, it tries to build dph-seq before dph-prim-seq is completed.

Change History (4)

comment:1 Changed 4 years ago by benl

  • Owner set to benl

Does this still fail with the latest version? I added some extra make dependencies on 24th of June that I was hoping would fix this.

comment:2 Changed 4 years ago by

  • Architecture changed from x86_64 (amd64) to Unknown/Multiple

Yes, still failed with yesterday's HEAD (btw., also fails on my 32-bit box with the same error).

comment:3 Changed 4 years ago by simonmar

FWIW, I just saw this on x86/Linux too.

comment:4 Changed 4 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.