Opened 4 years ago

Closed 3 years ago

#5271 closed bug (worksforme)

Compilation speed regression

Reported by: augustss Owned by:
Priority: normal Milestone: 7.4.1
Component: Compiler Version: 7.0.4
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Compile-time performance bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Ghc has gotten slower at compiling.
Compilation time for our code base in 6.12.4 was 23:40, and with the 7.0.4 it is 29:30. This is a 25% increase in compilation time. Both compilations with the same flags, -O2 being the most important one.

Change History (3)

comment:1 Changed 4 years ago by simonmar

  • Milestone set to 7.4.1
  • Status changed from new to infoneeded
  • Type of failure changed from None/Unknown to Compile-time performance bug

GHC hasn't got uniformly slower at compiling (we do check when making a release), but sometime what happens is that some crucial bit of code gets inlined where it wasn't before (or vice versa) and that causes knock-on effects.

So to investigate this we'll need more information.

comment:2 Changed 4 years ago by augustss

I would think that our compilation is a fairly good benchmark because it is about 200,000 lines of Haskell, so it uses all kinds of features. I can't give you the code, so I'm not sure how to provide more information.

We can let this one rest for now, and we'll check if the regression still exists in 7.2.1.

comment:3 Changed 3 years ago by igloo

  • Resolution set to worksforme
  • Status changed from infoneeded to closed

If you still think there's a problem, please reopen and include some way for us to reproduce the problem.

Note: See TracTickets for help on using tickets.