Opened 3 years ago

Closed 3 years ago

#5270 closed bug (worksforme)

Installing ghc ruins PATH on Windows

Reported by: augustss Owned by: igloo
Priority: highest Milestone: 7.2.1
Component: None Version: 7.0.4
Keywords: Cc:
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I installed ghc-7.0.4 on a Windows XP machine and after that the Path environment variable was pretty much destroyed. About half the string was ok, and then it was just junk.

Change History (6)

comment:1 Changed 3 years ago by igloo

Was this installing from this installer?:
http://www.haskell.org/ghc/dist/7.0.4/ghc-7.0.4-i386-windows.exe

Is the problem reproducible for you?

Where are you seeing the corrupted path (e.g. is it when doing "echo %PATH% in a cmd window, or what?)?

How long was the path before installation?

Where were you installing to?

comment:2 Changed 3 years ago by igloo

  • Status changed from new to infoneeded

comment:3 Changed 3 years ago by augustss

I didn't try reproducing it. It's bad enough to have it happen once.

The corrupted PATH was visible both in the control panel and looking at the environment variable in cmd and cygwin.

I'm not sure how long the path was, I never managed to recover it fully. Not overly long, maybe 1k.

I was installing to the default location.

comment:4 Changed 3 years ago by igloo

  • Status changed from infoneeded to new

comment:5 Changed 3 years ago by igloo

  • Milestone set to 7.2.1
  • Owner set to igloo
  • Priority changed from normal to highest

I'll see if I can reproduce it with the 7.2.1 RC, when we have one.

comment:6 Changed 3 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this. Please reopen if you find a way to reproduce it.

Note: See TracTickets for help on using tickets.